OriginLab Corporation - Data Analysis and Graphing Software - 2D graphs, 3D graphs, Contour Plots, Statistical Charts, Data Exploration, Statistics, Curve Fitting, Signal Processing, and Peak Analysis     
 
Skip Navigation Links
All BooksExpand All Books
Origin HelpExpand Origin Help
MinitoolsExpand Minitools

Minitool Cluster (nur OriginPro)

Video Image.png Weitere relevante Videos: Minitool Cluster

Übersicht

Das Minitool Cluster wird verwendet, um Datenpunkte innerhalb der ROI (Region of Interest) zu bearbeiten, z.B. zu entfernen, zu maskieren, zurückzusetzen etc. Dieser Dialog besteht aus zwei Bereichen. Der obere Bereich enthält Hilfsmittel, um die Datenpunkte der ROI zu bearbeiten, während der untere Bereich die statistischen Informationen anzeigt.

Cluster Gadget Overview.png

Um das Minitool Cluster zu verwenden, wählen Sie Minitools: Clustermanipulation im Hauptmenü bei aktivem Diagramm.

Hinweise:
  • Die Statistikergebnisse im unteren Bereich werden angezeigt, sobald Sie die grafische Datenauswahl verschieben oder in der Größe verändern.
  • Klicken Sie mit der rechten Maustaste in das Ergebnisfeld, um das Kontextmenü aufzurufen, das Ihnen erlaubt, die in die Berechnung einzuschließenden Datenzeichnungen zu wechseln.
  • Operationen wie Maskieren und Löschen werden über Schaltflächen in dem Dialog gesteuert. Das Menü Daten kann verwendet werden, um zu bestimmen, welche Datenzeichnungen von diesen Schaltflächen beeinflusst werden.

Die Schaltflächen des Dialogs dieses Minitools

Diese Schaltflächen werden verwendet, um Datenpunkte innerhalb des ROI-Bereichs zu bearbeiten. Sie können über das Menü Daten Zeichnungen bearbeiten. Sie können auch die Optionen im Menü Bearbeiten verwenden, um Datenpunkte zu bearbeiten.

Statistikbericht ausgeben

Region stats outputstats.png

Klicken Sie auf die Schaltfläche, um den Statistikbericht auszugeben. Der Inhalt des Berichts kann in den Einstellungen der Clustermanipulation festgelegt werden.
Zum Berichtsblatt gehen

Region stats gotoreport.png

Klicken Sie hier, um zum Ergebnisblatt zu wechseln. Sie ist nur verfügbar, nachdem das Berichtsblatt erstellt wurde.
Zum Quellarbeitsblatt gehen

Region stats gotosource.png

Klicken Sie hier, um zum Arbeitsblatt für die ausgewählten Datenpunkte zu wechseln. Wenn Zeichnungen aus verschiedenen Arbeitsblättern stammen, geht Origin zu dem Arbeitsblatt der ersten ausgewählten Zeichnung.
Innere/Äußere Punkte bearbeiten

Region stats switchiopoints.png

Klicken Sie hier, um zu bestimmen, ob die Punkte innerhalb bzw. außerhalb der grafischen Datenauswahl durch Operationen wie Daten maskieren und löschen bearbeitet werden. Der Titel des Dialogs weist auf den Status dieser Schaltfläche hin.
Letzte Änderung rückgängig

Region stats undo.png

Klicken Sie auf diese Schaltfläche, um die letzte Operation rückgängig zu machen.
Daten kopieren

Region stats copy.png

Klicken Sie auf diese Schaltfläche, um die Werte der ausgewählten Datenpunkte zu kopieren.
Daten löschen

Region stats clear.png

Klicken Sie auf diese Schaltfläche, um die Zellen der ausgewählten Datenpunkte im Quellarbeitsblatt zu löschen.
Arbeitsblattzeilen löschen

Region stats delete.png

Klicken Sie auf diese Schaltfläche, um die Zeilen, die den Zellen der ausgewählten Datenpunkte im Quellarbeitsblatt entsprechen, zu löschen.
Datenpunkte maskieren

Region stats maskdp.png

Klicken Sie auf diese Schaltfläche, um die Zellen der ausgewählten Datenpunkte im Quellarbeitsblatt zu maskieren.
Maskierung der Datenpunkte aufheben

Region stats unmaskdp.png

Klicken Sie auf diese Schaltfläche, um die Maskierung der Zellen der ausgewählten Datenpunkte im Quellarbeitsblatt aufzuheben.
Kategorien erstellen

Region stats create categories.png

Erstellen Sie eine Kategoriegruppe, fügen Sie Daten innerhalb der aktuellen grafischen Datenauswahl (ROI) zu dieser Gruppe hinzu und legen Sie kategoriale Werte fest. Sie öffnen den Dialog Kategorialen Wert erstellen durch Klicken auf diese Schaltfläche, mit dem Sie eine Kategorien festlegen können. Es werden Kategoriegruppenspalten zum Quellarbeitsblatt hinzugefügt.
Wert festlegen

Region stats set.png

Klicken Sie auf diese Schaltfläche, um die Werte der ausgewählten Datenpunkte in dem Quellarbeitsblatt auf einen gegebenen Wert im Bearbeitungsfeld auf der rechten Seite festzulegen.
Unteren Bereich zeigen/verbergen

Region stats hide.png

Klicken Sie auf diese Schaltfläche, um den unteren Bereich des Dialogs zu zeigen/zu verbergen.
Hinweise:
  • Diese Bearbeitungsschaltflächen (wie Daten löschen, Arbeitszeilen löschen, Datenpunkte maskieren, Maskierung der Datenpunkte aufheben, Wert festlegen) werden deaktiviert, wenn gesperrte Analysezeichnungen ausgewählt sind.
  • In einer Kategoriegruppe sollte ein Datenpunkt nur zu einer Kategorie gehören. Wenn ein Datenpunkt zuerst für eine Gruppe festgelegt ist und dann für eine andere, überschreibt die neue Zuweisung die ältere.

Kategoriale Werte erstellen

Region stats create categories dialog.png

Erstellen Sie eine Kategorie mit den Datenpunkten im aktuellen ROI-Feld und legen Sie den Wert fest.

Kategoriegruppenname Geben Sie einen Namen für die Kategoriegruppe ein.
Kategorie Geben Sie einen Kategoriewert für die Gruppe ein. Es kann sich hierbei um numerische Daten oder eine Textzeichenkette handeln.
Gruppenspalte für jede Datenzeichnung hinzufügen Legen Sie fest, ob die Kategoriegruppenspalte nur für die ausgewählte(n) Zeichnung(en) (über das Menü Daten) oder Gruppenspalten für alle Zeichnungen in dem Layer, eine für jede Zeichnung, hinzugefügt werden sollen. Diese Option ist standardmäßig deaktiviert.

Einstellungen des Dialogs dieses Minitools

Bearbeiten

Verwenden Sie diese Menüoptionen, um die ausgewählten Datenpunkte im Quellarbeitsblatt zu bearbeiten.

Rückgängig Die letzte Aktion wird rückgängig gemacht.
Daten kopieren Die Werte der ausgewählten Datenpunkte werden kopiert.
Daten löschen Die Zellen der ausgewählten Datenpunkte im Quellarbeitsblatt werden gelöscht.
Arbeitsblattzeilen löschen Die Zeilen, die den Zellen der ausgewählten Datenpunkte im Quellarbeitsblatt entsprechen, werden gelöscht.
Datenpunkte maskieren Die Zellen der ausgewählten Datenpunkte im Quellarbeitsblatt werden maskiert.
Maskierung der Datenpunkte aufheben Die Maskierung der Zellen der ausgewählten Datenpunkte im Quellarbeitsblatt wird aufgehoben.
Kategorien erstellen Erstellen Sie eine Kategoriegruppe, fügen Sie Daten innerhalb der aktuellen grafischen Datenauswahl in diese Gruppe hinzu und legen Sie kategoriale Werte fest. Der Dialog Kategoriale Werte erstellen wird geöffnet, indem Sie dieses Menü auswählen, mit dem Sie eine Kategorie festlegen können. Es wird eine Kategoriegruppenspalte oder -spalten neben der/n Datenzeichnung(en) in das Quellarbeitsblatt eingefügt.
Hinweis: Diese Menüoptionen (wie Daten löschen, Arbeitszeilen löschen, Datenpunkte maskieren, Maskierung der Datenpunkte aufheben) werden deaktiviert, wenn gesperrte Analysezeichnungen ausgewählt sind.

Daten

Dieses Menü legt fest, welche Datenzeichnungen durch Schaltflächen wie Daten löschen und maskieren beeinflusst werden.
Hinweis: Datenzeichnungen und Statistiken, die im unteren Bedienfeld angezeigt werden, werden nicht von diesem Menü beeinträchtigt. Um die Einträge im unteren Bedienfeld zu steuern, klicken Sie mit der rechten Maustaste in das Feld und verwenden Sie das Kontextmenü.

Diagramm(e) Wählen Sie das n-te Diagramm im aktiven Layer.
Geschlossene(s) Analysediagramm(e) zeigen Bestimmen Sie, ob geschlossene Analysediagramme im Menü Daten gezeigt werden. Geschlossene (gesperrte) Diagramme werden normalerweise durch andere Analysehilfsmittel wie Anpassen, Glätten etc. erzeugt.
Alle Diagramme Alle Diagramme werden im Menü Daten aufgeführt. Beachten Sie, dass geschlossene Analysediagramme nicht ausgewählt werden, wenn sie nicht im Menü Daten angezeigt sind.
Innere Punkte Aktivieren Sie diese Option, um Datenpunkte innerhalb der ROI zu bearbeiten.
Äußere Punkte Aktivieren Sie diese Option, um Datenpunkte außerhalb der ROI zu bearbeiten.

Einstellungen

Kreisförmige grafische Datenauswahl verwenden Sie können die Form der ROI in kreisförmig oder rechteckig ändern.
Auf gesamten Diagrammbereich erweitern Die Breite und Höhe der grafischen Datenauswahl werden erweitert, so dass sie an alle ausgewählten Diagramme angepasst sind.
Auf gesamte Layerbreite erweitern Die Breite der grafischen Datenauswahl wird auf die Breite des ausgewählten Layers erweitert.
Auf gesamte Layerhöhe erweitern Die Höhe der grafischen Datenauswahl wird auf die Höhe des ausgewählten Layers erweitert.
Position von ROI zurücksetzen Die Position der grafischen Datenauswahl wird auf den Standardwert zurückgesetzt.
Zugehörige Schaltflächen anzeigen Legen Sie fest, ob die Schaltfläche Schließen und das Menü Kontext oben rechts in der grafischen Datenauswahl (ROI) angezeigt werden.
Echtzeitberechnung Echtzeitberechnung findet bei Verschieben der ROI statt. Es wird empfohlen, diese Optionen beim Arbeiten mit großen Datensätzen zu deaktivieren.
Speichern als <Standard> Speichern Sie die Einstellungen des aktuellen Dialogs als Standarddesign.
Design speichern Die aktuellen Einstellungen des Dialogs werden als Design gespeichert.
Design laden Ein Design aus der Designliste wird geladen.
Einstellungen Rufen Sie den Dialog Cluster-Manipulation Einstellungen auf, um das Minitool benutzerdefiniert anzupassen.

Die Einstellungen auf dem Dialog Einstellungen

Dieser Dialog kann geöffnet werden über die Auswahl von

  1. die Auswahl von Minitools: Clustermanipulation im Origin-Menü.
  2. die Auswahl von Einstellungen: Einstellungen im Menü des Minitools Cluster.
  3. Wählen Sie Einstellungen im Ausklappmenü der grafischen Datenauswahl.

Grafische Datenauswahl (ROI)

Schaltfläche Schließen und Kontextmenü zeigen Legen Sie fest, ob die Schaltfläche Schließen und das Menü Kontext oben rechts in der grafischen Datenauswahl (ROI) angezeigt werden.
Toolname zeigen Legen Sie fest, ob der Name des Hilfsmittels oben in der grafischen Datenauswahl gezeigt werden soll.
Füllfarbe Legen Sie die Füllfarbe der grafischen Datenauswahl fest.
Farbe der inneren Punkte Legen Sie fest, ob die Farbe der Streupunkte, die mit der ROI ausgewählt sind, geändert werden soll.
Form Legen Sie die Form der grafischen Datenauswahl fest. Sie kann entweder rechteckig oder kreisförmig sein.
Position der Form Mit dieser Gruppe von Einstellungen können Sie die Position der grafischen Datenauswahl genau setzen. Wenn Kreis in der Auswahlliste Form ausgewählt ist, definieren die Einstellungen unten ein Rechteck, dessen Seiten tangential zum Kreis der grafischen Datenauswahl liegen.
  • X1: Legt die linke X-Position des Rechtecks fest.
  • X2: Legt die rechte X-Position des Rechtecks fest.
  • Y1: Legt die untere Y-Position des Rechtecks fest.
  • Y2: Legt die obere Y-Position des Rechtecks fest.

Ausgabe in

Skriptfenster Legen Sie fest, ob die Ergebnisse im Skriptfenster ausgegeben werden.
Ergebnisfenster Legen Sie fest, ob die Ergebnisse im Ergebnisfenster ausgegeben werden.
An Arbeitsblatt anhängen: Legen Sie fest, ob die Ergebnisse an das Arbeitsblatt angehängt werden.
Ergebnisblattname Diese Option ist nur verfügbar, wenn An Arbeitsblatt anhängen ausgewählt ist. Sie wird verwendet, um den Namen des Arbeitsblatts festzulegen. Die Standardeinstellung ist [RegionStats]Result.

Berechnung

Äußere Punkte berechnen Legen Sie fest, ob die Statistik für die Punkte außerhalb der grafischen Datenauswahl berechnet wird.
Echtzeitberechnung Legen Sie fest, ob das Echtzeitergebnis im Dialog des Minitools Cluster gezeigt werden soll, wenn die grafische Datenauswahl verschoben wird. Wenn dieses Kontrollkästchen deaktiviert ist, wird die Meldung "Echtzeitberechnung ist aus" oben rechts in der ROI angezeigt.
Legende des Quelldiagramms Legen Sie fest, ob der Legendentext für den Quelldatensatz ausgegeben wird.
Form Legen Sie fest, ob die Form der grafischen Datenauswahl ausgegeben wird.
Datenpunktinfo Diese Gruppe wird verwendet, um Datenpunktinfos für die Ausgabe festzulegen.
Indizes
Legen Sie fest, ob die Indizes der Datenpunkte ausgegeben werden.
Werte
Legen Sie fest, ob die Werte der Datenpunkte ausgegeben werden.
Statistik zu Diese Gruppe wird verwendet, um festzulegen, ob die statistischen Eigenschaften für X- oder Y-Werte berechnet werden.
X-Wert
Legen Sie fest, ob statistische Werte für die X-Koordinaten berechnet werden sollen.
Y-Wert
Legen Sie fest, ob statistische Werte für die Y-Koordinaten berechnet werden sollen.
Zu berechnende Eigenschaften Diese Gruppe wird verwendet, um die zu berechnenden statistischen Werte festzulegen.
N
Legen Sie fest, ob die Anzahl der Datenpunkte ausgegeben wird.
Sum
Legen Sie fest, ob die Summe der Datenpunkte ausgegeben wird.
Mittelwert
Legen Sie fest, ob der Mittelwert der Datenpunkte ausgegeben wird.
Median
Legen Sie fest, ob der Median der Datenpunkte ausgegeben wird.
StAbw.
Legen Sie fest, ob die Standardabweichung der Datenpunkte ausgegeben wird.
Minimum
Legen Sie fest, ob der Minimumwert der Datenpunkte ausgegeben wird.
Maximum
Legen Sie fest, ob der Maximumwert der Datenpunkte ausgegeben wird.

Kontextmenü im unteren Bedienfeld

Ergebnisse aller Diagramme in der Grafik werden hier in Zeilen aufgelistet. Verschiedene Größen der Statistikergebnisse werden in verschiedenen Spalten aufgeführt.

Kontextmenü durch Rechtsklick auf einen Spaltentitel

Region stats iotab.png

Klicken Sie mit der rechten Maustaste auf einen Spaltentitel, um das Kontextmenü aufzurufen und festzulegen, welche Statistik hier gezeigt werden soll.

Hinweise: Der Inhalt des ausgegebenen Statistikberichts wird im Dialog Cluster-Manipulation Einstellungen festgelegt, nicht hier im Kontextmenü.

Kontextmenü, das durch Rechtsklick auf eine der Zellen aufgerufen wird

Region stats iotab2.png

Klicken Sie mit der rechten Maustaste auf die Zellen, um das Kontextmenü aufzurufen, und wählen Sie aus, für welche Zeichnungen die Statistikergebnisse angezeigt werden sollen.

Hinweise: Die Zeichnungen, die Sie bearbeiten, werden über das Menü Daten gesteuert, nicht hier im Kontextmenü.

Das Ausklappmenü der grafischen Datenauswahl

Klicken Sie auf die dreieckige Schaltfläche ROI menu.png neben der oberen rechten Ecke der grafischen Datenauswahl, um das Ausklappmenü zu öffnen. Die Schaltfläche kann im Menü Einstellungen auf Zeigen oder Verbergen gesetzt werden und befindet sich sowohl im Dialog des Minitools Cluster als auch auf der Registerkarte Grafische Datenauswahl des Dialogs Cluster-Manipulation Einstellungen. Folgende Menübefehle stehen zur Verfügung:

Neue Statistikausgabe Wählen Sie diese Option, um die Ergebnisse an dem Zielort auszugeben, der auf der Registerkarte Ausgabe in des Dialogs Cluster-Manipulation Einstellungen festgelegt wurde.
Zum Berichtsblatt gehen Mit dieser Option wechseln Sie zum Ergebnisblatt. Sie ist nur verfügbar, nachdem das Berichtsblatt erstellt wurde.
Zum Quellarbeitsblatt gehen Mit dieser Option wechseln Sie zum Arbeitsblatt für die ausgewählten Datenpunkte. Wenn die Diagramme aus verschiedenen Arbeitsblättern stammen, wechselt Origin zu dem Arbeitsblatt des ersten ausgewählten Diagramms.
Daten ändern Wählen Sie die Diagramme und aktivieren/deaktivieren Sie die grafische Datenauswahl.
Diagramm(e)
Wählen Sie das n-te Diagramm im aktiven Layer.
Geschlossene(s) Analysediagramm(e) zeigen
Bestimmen Sie, ob im Ausklappmenü geschlossene Analysediagramm(e) gezeigt werden.
Alle Diagramme
Es werden alle Diagramme ausgewählt, die im Ausklappmenü aufgelistet sind. Beachten Sie, dass geschlossene Analysediagramme nicht ausgewählt sind, wenn sie nicht im Menü angezeigt werden.
Innere Punkte
Datenpunkte in der grafischen Datenauswahl (ROI) werden ausgewählt. Wenn diese Option aktiviert ist, werden die äußeren Punkte deaktiviert. Der Titel des Dialogs wird aktualisiert in "Innere Punkte bearbeiten".
Äußere Punkte
Datenpunkte außerhalb der grafischen Datenauswahl (ROI) werden ausgewählt. Wenn diese Option aktiviert ist, werden die inneren Punkte deaktiviert. Der Titel des Dialogs wird aktualisiert in "Äußere Punkte bearbeiten".
Auf gesamten Diagrammbereich erweitern Die Fläche der grafischen Datenauswahl wird erweitert, so dass alle ausgewählten Diagramme angepasst werden.
Auf gesamte Layerbreite erweitern Die Breite der grafischen Datenauswahl wird auf die Breite des ausgewählten Layers erweitert.
Auf gesamte Layerhöhe erweitern Die Höhe der grafischen Datenauswahl wird auf die Höhe des ausgewählten Layers erweitert.
Kreisförmige grafische Datenauswahl verwenden Legen Sie fest, ob eine kreisförmige ROI verwendet wird.
Design speichern Speichern Sie die Einstellungen des aktuellen Dialogs als ein Design. Dieser Vorgang öffnet den Dialog Design speichern unter. Sie können den Designnamen in dem Bearbeitungsfeld festlegen.
Speichern unter <Standard> Speichern Sie die Einstellungen des aktuellen Dialogs als Standarddesign.
Design laden Ein Design aus der Designliste wird geladen.
Einstellungen Rufen Sie den Dialog Cluster-Manipulation Einstellungen auf, um das Minitool benutzerdefiniert anzupassen.

Beispiel

  1. Erstellen Sie ein neues Arbeitsblatt und importieren Sie die Datei Multiple Gaussians.dat, die sich im Ordner <Origin Program Folder>\Samples\Curve Fitting befindet.
  2. Markieren Sie das gesamte Arbeitsblatt und wählen Sie Zeichnen: Symbol: Punktdiagramm im Hauptmenü, um ein Diagramm zu erstellen.
  3. Wählen Sie Minitools: Clustermanipulation im Origin-Menü. Behalten Sie die Standardeinstellungen bei und klicken Sie auf OK. Ein gelbes ROI-Objekt wird zu der Zeichnung hinzugefügt, die Farbe der ausgewählten Streupunkte wird geändert, und der Dialog Minitools wird geöffnet.
  4. Wählen Sie Einstellungen: Zugehörige Schaltflächen zeigen im Menü des Dialogs Cluster. Die Schaltfläche Schließen und das Kontextmenü werden in der oberen, rechten Ecke der grafischen Datenauswahl angezeigt.
    Region stats graph.png
    Region stats graph2.png
  5. Verschieben Sie die grafische Datenauswahl und sehen Sie, wie sich die Ergebnisse ändern.
  6. Klicken Sie auf die Schaltfläche Datenpunkte maskieren im Dialog des Minitools Cluster, um die Daten im Quellarbeitsblatt zu maskieren. Sie werden sehen, dass die inneren Punkte in dem Quellarbeitsblatt maskiert sind.
    Region stats maskedwks.png

Algorithmus

Dieses Hilfsmittel führt deskriptive Statistik für eine Kurve im Diagrammfenster durch. Weitere Informationen zur Berechnung finden Sie unter dem Algorithmus der X-Funktion stats.

 

© OriginLab Corporation. Alle Rechte vorbehalten.