OriginLab Corporation - Data Analysis and Graphing Software - 2D graphs, 3D graphs, Contour Plots, Statistical Charts, Data Exploration, Statistics, Curve Fitting, Signal Processing, and Peak Analysis     
 
Skip Navigation Links
All BooksExpand All Books
Origin HelpExpand Origin Help
Workbooks Worksheets and Worksheet ColumnsExpand Workbooks Worksheets and Worksheet Columns
Simple Manipulation of Worksheet DatasetsExpand Simple Manipulation of Worksheet Datasets

Datenfilter

Origin bietet Datenfilter der drei Datenformate, Datum/Zeit, Numerisch und Text. Der Datenfilter könnte hinzugefügt, entfernt, aktiviert, deaktiviert oder erneut angewendet werden, indem auf die entsprechende Schaltfläche auf der Symbolleiste Worksheet-Daten geklickt wird, und mit den benutzerdefinierten Filterungsbedingungen benutzerdefiniert angepasst werden.

Inhalt

Datenfilter hinzufügen/entfernen

Um einen Datenfilter zu einer oder mehreren Spalten hinzuzufügen oder zu entfernen:

  1. Markieren Sie die gewünschte(n) Spalte(n).
  2. Klicken Sie auf die Schaltfläche Datenfilter hinzufügen/entfernen Button Add Remove Column Filter.png.

Wenn ein Datenfilter hinzugefügt wird, handelt es sich standardmäßig um einen leeren Filter, für den noch keine Filterungsbedingungen festgelegt sind. Sobald Filterungsbedingungen festgesetzt sind, wird der Filter automatisch nach der Filterbedingung benannt und das Filtersymbol wird vollständig mit grüner Farbe gefüllt.

Column Filter 001.png

Um einen Datenfilter zu entfernen, könnten Sie auch:

  1. Die gewünschte(n) Spalte(n) mit Datenfiltern markieren.
  2. Auf das Symbol Filter klicken und Filter löschen im Kontextmenü wählen.

Column Filter 002.png

Wenn ein Datenfilter entfernt oder gelöscht wird, ist es nicht möglich, die Filterungsbedingungen erneut zu verwenden.

Datenfilter aktivieren/deaktivieren

Wenn ein Datenfilter hinzugefügt wird, ist es möglich, ihn durch Folgendes entweder zu aktivieren oder zu deaktivieren:

  1. Markieren Sie die gewünschte(n) Spalte(n).
  2. Klicken Sie auf die Schaltfläche Datenfilter aktivieren/deaktivieren Button Enable Disable Column Filter.png.

oder

  1. Markieren Sie die gewünschte Spalte.
  2. Klicken Sie auf das Symbol Filter und rufen Sie das Kontextmenü auf. Aktivieren Sie Filter aktivieren für die Aktivierung und deaktivieren Sie das Kontrollkästchen, um den gegenteiligen Effekt zu erreichen.

Column Filter 003.png

Wenn im zweiten Fall mehrere Spalten ausgewählt sind, wird nur der Datenfilter der Spalte links außen deaktiviert/aktiviert.

Wenn ein Datenfilter deaktiviert ist, wird das Filtersymbol grau und vor dem Filternamen wird "Aus" eingeblendet.

Column Filter 004.png

Wenn Ihr ausgewählter Spaltenbereich sowohl aktivierte als auch deaktivierte Spalten umfasst, werden alle Spalten deaktiviert, sobald Sie auf die Schaltfläche Button Enable Disable Column Filter.png klicken.

Datenfilter erneut anwenden

Falls die Daten aktualisiert werden oder sich die Filterungsbedingungen ändern, könnten Sie den Datenfilter erneut anwenden, indem Sie auf die Schaltfläche Datenfilter erneut anwenden Button Reapply Column Filter.png klicken:

Datenfilter benutzerdefiniert anpassen

Origin erkennt den Datentyp und weist den entsprechenden Spalten automatisch einen der drei Datenfilter (Datum, Numerisch, Text) zu. Die Filterungsbedingungen müssen beim benutzerdefinierten Anpassen festgelegt werden.

Es gibt zwei Möglichkeiten, um einen Datenfilter benutzerdefiniert anzupassen.

  1. Klicken Sie auf das Symbol Filter, um das Kontextmenü aufzurufen.
  2. Für jeden Datenfiltertyp sind mehrere Schnellmenüelemente verfügbar. Wählen Sie einen, um den entsprechenden Dialog Einfacher Filter zu öffnen.
  3. Legen Sie die Bedingungen des Datenfilters fest und klicken Sie auf OK.

oder

  1. Klicken Sie auf das Symbol Filter, um das Kontextmenü aufzurufen.
  2. Wählen Sie Benutzerdefinierter Filter, um den Dialog Benutzerdefinierter Datenfilter zu öffnen.
  3. Legen Sie die Bedingungen des Datenfilters fest und klicken Sie auf Anwenden oder OK.

Column Filter 005.png

Menüoptionen und Dialogbedienelemente

Es gibt drei Typen des Spaltenfilters, für jeden Spaltentyp einen. Die entsprechenden Schnellmenüelemente und die Dialoge Benutzerdefinierter Datenfilter sind unterschiedlich.

Datumsfilter

Datumszeitfilter wird verwendet, wenn das Datenformat auf Datum gesetzt ist.


Das Schnellmenü bietet mehrere Optionen:

Ist gleich Der Dialog Einfacher Datumsfilter wird aufgerufen mit dem Standardformeltyp Gleich und einem Wert des aktuellen Datums.
Vorher Der Dialog Einfacher Datumsfilter wird aufgerufen mit dem Standardformeltyp Vor und dem Wert des aktuellen Datums.
Danach Der Dialog Einfacher Datumsfilter wird aufgerufen mit dem Standardformeltyp Nach und dem Wert des aktuellen Datums.
Zwischen Der Dialog Zwischen wird aufgerufen mit dem Minimum und Maximum als Standardwerte für Von und Bis.

Der Einfache Datenfilter hat die folgenden Optionen für Formeltypen:

Ist gleich Mit dieser Option behalten Sie die Zeilen, bei denen Datum und Zeit genau mit dem Anfragedatum und der -zeit übereinstimmen, und blenden die anderen aus.
Ist nicht gleich Mit dieser Option behalten Sie die Zeilen, bei denen Datum und Zeit nicht mit dem Anfragedatum und der -zeit übereinstimmen, und blenden die anderen aus.
Nach Mit dieser Option behalten Sie die Zeilen, bei denen Datum und Zeit nach dem Anfragedatum und der -zeit liegen, und blenden die anderen aus.
Während oder danach Mit dieser Option behalten Sie die Zeilen, bei denen Datum und Zeit nicht vor dem Anfragedatum und der -zeit liegen, und blenden die anderen aus.
Vor Mit dieser Option behalten Sie die Zeilen, bei denen Datum und Zeit vor dem Anfragedatum und der -zeit liegen, und blenden die anderen aus.
Während oder vorher Mit dieser Option behalten Sie die Zeilen, bei denen Datum und Zeit nicht nach dem Anfragedatum und der -zeit liegen, und blenden die anderen aus.

Das Feld Wert wird verwendet, um das angefragte Datum und/oder die Zeit, festzulegen. Der Standardwert ist das lokale Datum und die lokale Zeit des Computers. Es ist möglich, den Datumswert sowohl mit dem Kalender als auch durch direkte Eingabe festzulegen.

Die Bedingung 2 legt die logische Beziehung fest, falls zwei Anfragebedingungen gesetzt sind. Es bestehen folgende Optionen:

Kein Die zweite Filterbedingung wird nicht verwendet.
Und Die zweite Filterbedingung wird verwendet. Mit dieser Option können Sie die Zeilen behalten, bei denen das Datum und die Zeit für beide Anfragebedingungen wahr sind, und die anderen ausblenden.
Oder Die zweite Filterbedingung wird verwendet. Mit dieser Option können Sie die Zeilen behalten, bei denen das Datum und die Zeit für eine der beiden Anfragebedingungen wahr sind, und die anderen verbergen.

Sie können eine erweiterte Einstellung der Filterbedingungen mit dem Dialog Benutzerdefinierter Datenfilter durchführen. Klicken Sie auf Benutzerdefinierte Filter, um den Dialog aufzurufen.

Numerischer Filter

Der numerische Filter wird angewendet, wenn die ausgewählte Spalte nummerische Daten enthält.

Das Schnellmenü bietet mehrere Optionen:

Ist gleich Der Dialog Einfacher numerischer Filter wird aufgerufen mit dem Standardformeltyp Gleich und dem ersten Wert in der aktuellen Spalte.
Weniger als Der Dialog Einfacher numerischer Filter wird aufgerufen mit dem Standardformeltyp Weniger als und dem ersten Wert in der aktuellen Spalte.
Größer als Der Dialog Einfacher numerischer Filter wird aufgerufen mit dem Standardformeltyp Größer als und dem ersten Wert in der aktuellen Spalte.
Zwischen Der Dialog Zwischen wird aufgerufen mit dem Minimum und Maximum als Standardwerte für Von und Bis.
Oberen 10 Der Dialog Oberen N wird mit der Standardfilterbedingung für die oberen 10 Elemente aufgerufen.
Unteren 10 Der Dialog Oberen N wird mit der Standardfilterbedingung für die unteren 10 Elemente aufgerufen.

Der Einfache numerische Filter hat die folgenden Optionen für Formeltypen:

Ist gleich Mit dieser Option können Sie die Zeilen behalten, bei denen der Zellenwert gleich der Anfragezahl ist, und die anderen ausblenden.
Ist nicht gleich Mit dieser Option können Sie die Zeilen behalten, bei denen der Zellenwert nicht gleich der Anfragezahl ist, und die anderen ausblenden.
ist größer als Mit dieser Option können Sie die Zeilen behalten, bei denen der Zellenwert größer als die Anfragezahl ist, und die anderen ausblenden.
ist größer als oder gleich Mit dieser Option können Sie die Zeilen behalten, bei denen der Zellenwert größer als oder gleich der Anfragezahl ist, und die anderen ausblenden.
ist kleiner als Mit dieser Option können Sie die Zeilen behalten, bei denen der Zellenwert kleiner als die Anfragezahl ist, und die anderen ausblenden.
ist kleiner als oder gleich Mit dieser Option können Sie die Zeilen behalten, bei denen der Zellenwert kleiner als oder gleich der Anfragezahl ist, und die anderen ausblenden.

Die Bedingung 2 legt die logische Beziehung fest, falls zwei Anfragebedingungen gesetzt sind. Es bestehen folgende Optionen:

Kein Die zweite Filterbedingung wird nicht verwendet.
Und Die zweite Filterbedingung wird verwendet. Mit dieser Option können Sie die Zeilen behalten, bei denen das Datum und die Zeit für beide Anfragebedingungen wahr sind, und die anderen ausblenden.
Oder Die zweite Filterbedingung wird verwendet. Mit dieser Option können Sie die Zeilen behalten, bei denen das Datum und die Zeit für eine der beiden Anfragebedingungen wahr sind, und die anderen verbergen.

Der Dialog Benutzerdefinierter Datenfilter wird aufgerufen, indem Sie im Menü auf Benutzerdefinierte Filter klicken. Er wird verwendet, um erweitere Einstellungen der Filterbedingungen vorzunehmen.

Textfilter

Der Textfilter wird angewendet, wenn das Datenformat der ausgewählten Spalte Text, Monat oder Tag der Woche ist.

Sie können im Schnellmenü die Kontrollkästchen für die entsprechenden Texteinträge aktivieren/deaktivieren, um sie beizubehalten/auszublenden.

Column Filter Menu 002.png

Klicken Sie im Schnellmenü auf Benutzerdefinierte Filter, um den Dialog Benutzerdefinierte Filter (Einfacher Text) aufzurufen.

Column Filter Menu 003.png

Die Spalte Eintrag führt alle eindeutigen Texteinträge des ausgewählten Bereichs auf. Die Spalte Anzahl enthält die Häufigkeit der entsprechenden Texteinträge in dem ausgewählten Bereich.

Klicken Sie auf eine der beiden Spaltenköpfe, und die Ergebnisse werden sortiert in dem Datenbedienfeld in aufsteigender oder absteigender Reihenfolge angezeigt.

Die Kontrollkästchen links werden verwendet, um festzulegen, ob die Zeilen mit dem entsprechenden Eintrag ausgeblendet werden sollen oder nicht. Wenn es aktiviert ist, werden die entsprechenden Zeilen nicht ausgeblendet.

Es gibt drei Schaltflächen auf der rechten Seite:

Alles markieren Alle Kontrollkästchen werden aktiviert.
Alle umschalten Der Status aller Kontrollkästchen wird umgekehrt, so dass die aktivierten Kästchen deaktiviert werden und umgekehrt.
Alle löschen Alle Kontrollkästchen werden deaktiviert.
Nach Verwenden des Textfilters enthält die Beschriftungszeile Filter eine Liste der Texteinträge, die nicht mit dem Filter verborgen wurden. Standardmäßig werden die Einträge in dieser Zelle durch ein Leerzeichen getrennt. Die Systemvariable @TFS kann verwendet werden, um die Trennzeichen zu wechseln: 0=Enter, 1=Leerzeichen, 2=Komma, 3=Semikolon.

Zusätzlich gibt es eine weitere Systemvariable @TFL, die verwendet werden kann, um die maximale Länge der Textfilterbeschriftung festzulegen. Der Standardwert ist 50. Die erste und letzte Zeichenkette werden immer angezeigt und der Rest der Zeichenketten wird als "..." angezeigt.

Aktivieren Sie das Kontrollkästchen Erweitert. Dadurch wird der Dialog Benutzerdefinierter Filter (Erweiterter Text) aufgerufen.

Column Filter Menu 004.png

Das Feld für die Bedingung wird verwendet, um Filterbedingungen einzugeben. Sie können auf die dreieckige Schaltfläche klicken, um das Ausklappmenü zu öffnen, mit dem Sie die zugehörigen Funktionen aufrufen können.

Das Feld Skript vor Bedingung wird verwendet, um das Labtalk-Skript zu definieren, das vor der Filterung ausgeführt wird.

i kann im Feld Bedingung verwendet werden, um den Zeilenindex zu ersetzen, z.B., bezeichnet i>15 die Zeilen nach der 15. Zeile. Es kann ebenfalls im Dialog Benutzerdefinierter Datenfilter verwendet werden.

Die Steuerung von Platzhaltern wird unterstützt. Die folgenden Tabellen enthalten einige Tipps dazu, wie der erweiterte Textfilter verwendet wird, um Ihre Arbeit effizienter zu machen.

Verwendung von Sonderzeichen im Feld des erweiterten Textfilters
Symbol Verwendung
? (Fragezeichen) Steht für ein einzelnes Zeichen, z.B. "a?c" findet "abc" oder "adc", aber nicht "abbc".
* (Sternchen) Steht für Zeichenketten mit beliebig vielen Zeichen, z.B. "abc*e" findet "abcde" oder "abcdde" oder "abce".
== (zwei Gleichheitszeichen) Steht für volle Entsprechung, z.B. x=="a*" findet genau "a*", aber nicht "abc".

Das folgende Kurztutorial zeigt Ihnen, wie Sie die Steuerung der Platzhalter für den Textfilter verwenden.

  1. Importieren Sie die Datei Automobile.dat aus \Samples\Statistics\ in Origin.
  2. Markieren Sie Spalte B und klicken Sie auf die Schaltfläche Datenfilter hinzufügen/entfernen Button Add Remove Column Filter.png.
  3. Klicken Sie auf das Symbol Filter und wählen Sie Benutzerdefinierte Filter.

    Column Filter 006.png

  4. Aktivieren Sie das Kontrollkästchen Erweitert.
  5. Geben Sie in dem Anfragefeld Folgendes ein:
    x LIKE "S*"
  6. Klicken Sie auf OK und dann auf Ja für die Erinnerungsmeldung (falls es eine gibt).
  7. Wechseln Sie zurück zu dem Originalarbeitsblatt. Nur die Zeilen, deren Text mit einem "s" beginnen, werden gezeigt.

Dialog Benutzerdefinierter Datenfilter

Der Dialog Benutzerdefinierter Datenfilter wird verwendet, um erweiterte Einstellungen der Filterbedingungen von Datums- und numerischen Filtern vorzunehmen.

Column Filter Menu 001.png

Das Feld für die Bedingung wird verwendet, um Filterbedingungen einzugeben. Sie können auf die dreieckige Schaltfläche klicken, um das Ausklappmenü zu öffnen, mit dem Sie die zugehörigen Funktionen aufrufen können.

Das Feld Skript vor Bedingung wird verwendet, um das Labtalk-Skript zu definieren, das vor der Filterung ausgeführt wird.

Vier Schaltflächen stehen zur Verfügung:

Test Die Zeilen, die die Filterbedingung erfüllen, werden im Originalarbeitsblatt markiert. Das sind die Zeilen, die nach der Filterung gezeigt werden.
OK Die Änderung der Filterbedingungen wird angewendet und der Dialog geschlossen.
Abbrechen Schließen Sie den Dialog, ohne die Modifikation der Filterbedingungen anzuwenden.
Anwenden Die Änderung der Filterbedingungen wird angewendet, ohne den Dialog zu schließen.

Für den numerischen Filter sind einige integrierte Labtalk-Funktionen nicht im Ausklappmenü enthalten. Die Tabelle unten bietet implementierte Informationen zu diesen Funktionen:

Verwendung von einigen Labtalk-Funktionen im numerischen Filter
Ausdruck Verwendung
x.between(x1,x2) Sie kehren zum Unterbereich von x zwischen den vom Anwender eingegebenen Werten x1 und x2 zurück, was gleich
x<=x2 && x>=x1
.
x.top(n,0/1) Sie kehren zu den größten n-Werten von x zurück; wenn 0 gewählt ist, ist n die Anzahl der Elemente, wenn 1 gewählt ist, ist n die Prozentzahl.
x.bottom(n,0/1) Sie kehren zu den kleinsten n-Werten von x zurück; wenn 0 gewählt ist, ist n die Anzahl der Elemente, wenn 1 gewählt ist, ist n die Prozentzahl.


Für Filter von Text-/Numerischen/Datumsdaten unterstützt Origin auch die Funktion x.count(), um die Anzahl der duplizierten Daten zu zählen.

Zum Beispiel: Um Textdaten zu behalten, deren Zahl über 3 ist, können Sie im Benutzerdefinierten Datenfilter Folgendes festlegen:

Bedingung: x.count() > 3

Verborgene Zeilen ignorieren

Es ist möglich zu wählen, ob die Zeilen durch einen Datenfilter in der Datenanalyse und/oder während des Zeichnens verborgen werden. Standardmäßig werden alle verborgenen Zeilen ignoriert. Um verborgene Zeilen in der Datenanalyse oder während des Zeichens nicht zu ignorieren, tun Sie Folgendes:

  1. Aktivieren Sie ein Arbeitsblatt.
  2. Führen Sie das Skript im Befehlsfenster aus:
wks.ignorehidden = 0;

oder

  1. Wählen Sie im Menü Format: Worksheet oder drücken Sie F4, um den Dialog Arbeitsblatteigenschaften zu öffnen.
  2. Deaktivieren Sie auf der Registerkarte Verschiedenes das Kontrollkästchen Verborgene Zeilen beim Zeichnen und Analysieren ignorieren.
Hinweis: Für den LT-Zugriff und im Dialog Werte setzen werden wir verborgene Zeilen niemals ignorieren.

Beim Anwenden der Maskierung und Hinzufügen eines Datenfilters auf die Spaltendaten, werden die maskierten Daten standardmäßig noch in der Spalte gezeigt.

Die Systemvariable @FBM steuert, ob die maskierten Daten der Spalte mit dem Datenfilter gezeigt werden.

  • 0: Verbergen
  • 1: Zeigen

Datenfilter in Operation speichern

Im Kontextmenü des Schlosssymbols Neu berechnen für Spalten kopieren in... und Pivot-Tabelle gibt es drei Optionen für den Arbeitsblattfilter. Diese werden verwendet, um festzulegen, ob die Ergebnisse durch weitere Filteränderungen beeinflusst werden.

Hinweis: Der Modus Neu berechnen von Spalte kopieren und Pivot-Tabelle sollte auf Auto oder Manuell gesetzt sein.

Filters Lock.png

Arbeitsblattfilter: Blockieren

Wenn diese Option ausgewählt ist, wird das Ergebnis für eine Änderung der Datenfilterbedingung bezüglich der Quellspalte(n) gesperrt. Das heißt, wenn die Filterbedingung im Quellspaltenarbeitsblatt geändert wird, wird keine Aktualisierung der Ergebnisspalten ausgelöst.

Arbeitsblattfilter: Neu laden

Diese Option ist nur verfügbar, wenn Arbeitsblattfilter: Blockieren bereits ausgewählt ist. Die Datenfilterbedingung wird von den Quellspalte(n) für die Ergebnisspalte(n) neu geladen. Das heißt, nachdem Sie die Bedingung für den Datenfilter der Quellspalte(n) geändert haben, klicken Sie auf diese Option, um die automatische Aktualisierung der gesperrten Ergebnisspalte(n) auszulösen, um die gleiche Filterbedingung auch auf die Ergebnisspalte(n) anzuwenden.

Arbeitsblattfilter: Auf Quellarbeitsblatt anwenden

Diese Option ist nur verfügbar, wenn Arbeitsblattfilter: Blockieren bereits ausgewählt ist. Die ursprüngliche Datenfilterbedingung wird auf die Quellspalte(n) angewendet. Das heißt, nachdem Sie die Datenfilterbedingung des Quellarbeitsblatts geändert haben, klicken Sie auf diese Option, und die jüngste Datenfilterbedingung, die von den Quellspalten auf die Ergebnisspalten angewendet wurde, wird für das Quellarbeitsblatt verwendet. Beachten Sie, dass, wenn Sie einen Datenfilter direkt auf die Ergebnisspalte(n) angewendet haben, er nicht wieder auf die Quelle angewendet wird.

 

© OriginLab Corporation. Alle Rechte vorbehalten.