OriginLab Corporation - Data Analysis and Graphing Software - 2D graphs, 3D graphs, Contour Plots, Statistical Charts, Data Exploration, Statistics, Curve Fitting, Signal Processing, and Peak Analysis     
 
Skip Navigation Links
All BooksExpand All Books
User GuideExpand User Guide

Diagramme benutzerdefiniert anpassen

Grand image customizing graphs3.png

Einführung

Dieses Kapitel führt Sie in verschiedene Aspekte der benutzerdefinierten Diagrammanpassung ein. Alle Origin-Diagramme werden aus einer Diagrammvorlage erstellt. Wenn das Diagramm ein für seinen Typ standardmäßiges ist, sind die in der Diagrammvorlage gespeicherten Optionen möglicherweise vollkommen angemessen, um ein sinnvoll aussehendes Diagramm zu erstellen. Das Erstellen von Diagrammen wurde grundlegend im letzten Kapitel Grafische Darstellung beschrieben.

Früher oder später werden Sie jedoch Anmerkungen hinzufügen, Achsenskalierungen oder Zeichnungsfarben ändern wollen. Daher zielt dieses Kapitel darauf ab, Ihnen einige von Origins Hilfsmitteln und Methoden der benutzerdefinierten Anpassung von Diagrammen nahe zu bringen und Sie auf Ressourcen hinzuweisen, die Ihnen dabei helfen können, komplexe Anpassungsaufgaben von Diagrammen zu bewerkstelligen.

Wir beginnen mit der Beschreibung der Symbolleisten für die benutzerdefinierte Anpassung von Diagrammen, da diese Symbolleisten über Hilfsmittel verfügen, die häufig für schnelle Modifikationen von Diagrammelementen verwendet werden.

Symbolleisten

Symbolleistenschaltflächen für Aufgaben der benutzerdefinierten Diagrammanpassung:

Beschreibung Symbolleiste
(Standardkonfiguration)
Schaltflächen der Symbolleiste Format:
  • Textobjekte erstellen und benutzerdefiniert anpassen
Format bar.png
Schaltflächen der Symbolleiste Stil:
  • Farben, Linienstärke, Füllmuster bearbeiten
Style bar.png
Schaltflächen der Symbolleiste Hilfsmittel:
  • Textobjektw, Linien, Pfeile, Rechtecke/Kreise/Polygone hinzufügen
Tools bar.png
Schaltflächen der Symbolleiste Diagramm:
  • Diagrammlayer hinzufügen inkl. Diagramme einfügen, Diagramme zusammenfügen oder extrahieren; Achsen austauschen; Anti-Aliasing und Entwurfsmodus
Graph toolbar 92-vNext.png
Schaltflächen der Symbolleiste Objekt zu Diagramm hinzufügen:
  • Legenden/Farbskalen/Blasenskala, Stempel mit Datum & Zeit sowie Projektpfad, XY-Skala und Tabellenobjekte hinzufügen
Add Object to Graph Toolbar.png
Schaltflächen der Symbolleiste Objekt bearbeiten:
  • Objekte und Layer auf der Seite anordnen und ausrichten
Object Edit bar.png

Menüs und Dialoge

Viele Diagrammanpassungen werden über Befehle im Menü Grafik durchgeführt. Optionen für die benutzerdefinierte Anpassung werden in den unten stehenden Abschnitten erläutert.

Die folgende Tabelle führt die Dialoge auf, die hauptsächlich für die Anpassung von Diagrammen verwendet werden:

Aufgabe Dialogname Methode
Diagrammseite, Layer oder Datenzeichnung benutzerdefiniert anpassen
  • Dialog Details Zeichnung
  • Doppelt auf Seite, Layer oder Datenzeichnung klicken
  • Menü Format: Seiteneigenschaften
  • Menü Format: Layereigenschaften
  • Menü Format: Diagrammeigenschaften
Achsen benutzerdefiniert anpassen,
  • Dialog Achsen
  • Doppelt auf Achsen oder Hilfsstrichsbeschriftungen klicken
  • Menü Format: Achsen
  • Menü Format: Achsenbeschriftung
  • Menü Format: Achsentitel
Legende hinzufügen oder benutzerdefiniert anpassen
  • Dialog Legende aktualisieren
  • Registerkarte Legenden/Titel auf der Ebene Seite des Dialogs Details Zeichnung
  • Mit der rechten Maustaste auf Legende klicken und Legende: Legende aktualisieren wählen
  • Menü Grafik: Legende: Legende aktualisieren
  • Registerkarte Legenden/Titel auf der Ebene Seite des Dialogs Details Zeichnung
Mehrere Diagrammfenster zu einem zusammenfügen
  • Dialog Grafikfenster zusammenfügen
  • Menü Grafik: Grafikfenster zusammenfügen.
Benutzerdefinierte Anpassung auf Layerebene: Layer in der Größe verändern, verschieben, austauschen, ausrichten oder hinzufügen
  • Dialog Layerverwaltung
  • Menü Grafik: Layerverwaltung
Einstellungen als Diagrammvorlage speichern
  • Dialog Template speichern unter
  • Menü Datei: Template speichern unter
  • Mit der rechten Maustaste auf den Fenstertitel klicken und Template speichern unter wählen
Diagrammvorlagen verwalten, Zeichnungen zu einer Vorlage hinzufügen
  • Vorlagenbibliothek (benutzerdefinierte Diagrammvorlagen)
  • Systemvorlagen (Standarddiagrammvorlagen)
  • Menü Zeichnen > Vorlagen: mit Template
  • Menü Zeichnen > Vorlagen: Systemvorlagenbibliothek
Einstellungen als Diagrammdesign speichern
  • Dialog Format als Design speichern
  • Mit der rechten Maustaste klicken und im Kontextmenü Format als Design speichern wählen
Diagrammdesigns verwalten: Designs bearbeiten, kombinieren, anwenden, als Systemdesign festlegen
  • Dialog Designs verwalten
  • Hilfsmittel: Designs verwalten > Registerkarte Diagramm
  • Schnellzugriff über F7

Seite, Layer und Datenzeichnungen benutzerdefiniert anpassen

Ein Diagramm verfügt über eine Reihe von bearbeitbaren Eigenschaften auf drei Ebenen: Seite, Layer und Datenzeichnungen. Eine schnelle Formatierung einiger Diagrammeigenschaften kann mit Hilfe der Symbolleistenschaltflächen durchgeführt werden, wie oben beschrieben. Die große Mehrheit der Eigenschaften jedoch werden über Origins Dialog Details Zeichnung benutzerdefiniert angepasst (dieser wird Doppelklick auf Ihr Zeichnung oder Auswahl von Format: Seite/Layer/Diagrammeigenschaften im Menü geöffnet).

Die Abbildung unten zeigt ein Beispiel für den Dialog Details Zeichnung.

  • Das linke Bedienfeld zeigt die Hierarchie Seite > Layer > Zeichnung als erweiterbare/minimierbare Baumstruktur.
  • Das rechte Bedienfeld zeigt die Bedienelemente, die sich auf das aktuell im linken Bedienfeld ausgewählte Objekt beziehen.
  • Um ein Objekt benutzerdefiniert anzupassen, wählen Sie es im linken Bedienfeld aus und modifizieren seine Eigenschaften auf den verschiedenen Registerkarten im rechten Bedienfeld.
PD customizing graphs 2.png

Benutzerdefinierte Anpassungen können im Dialog Details Zeichnung RÜCKGÄNGIG gemacht werden.

  1. Klicken Sie auf OK, um Details Zeichnung zu schließen, und wählen Sie Bearbeiten: Rückgängig: Seite modifizieren oder drücken Sie STRG + Z.

 

Ausgewähltes Objekt im linken Bedienfeld Rechtes Bedienfeld, Bedienelemente für...
Seite Drucken/Druckbereich, Zeichenreihenfolge der Layer, Anzeigefarbe der Seite, Legenden/Titel
Layer Hintergrundfarbe des Layers, Layergröße und Entwurfsmodus, Layeranzeige, Stapeleinstellungen für entsprechende Diagrammtypen Einige Diagrammtypen verfügen über zusätzliche Registerkarten/Bedienelemente, die speziell auf den Diagrammtyp ausgerichtet sind.
Datenzeichnung Diagrammspezifische Eigenschaften; die Registerkarten und Bedienelemente beziehen sich auf den Diagrammtyp.
Datenpunkt Punktspezifische Eigenschaften; Verfügbar für einige Diagrammtypen Die Registerkarten und Bedienelemente ähneln im Allgemeinen denen auf Ebene der Datenzeichnung.


:PD customizing graphs 1a.png

Verhindern Sie die Skalierung von Text- und Beschriftungsobjekten, wenn Layer in der Größe verändert werden, indem Sie zur Registerkarte Anzeige des Dialogs Details Zeichnung (auf Layerebene) wechseln und den Festen Faktor auf 1setzen.

Gruppierte Zeichnungen benutzerdefiniert anpassen

Wenn Sie mehrere Datenbereiche in einem einzelnen Diagrammlayer auswählen und zeichnen, gruppiert Origin die Zeichnungen innerhalb des Layers. Standardmäßig werden gruppierte Zeichnungen automatisch unterschieden, indem eine oder mehrere Zeichnungseigenschaften variiert werden und indem anpassbare Inkrementlisten durchlaufen werden (eine für jede Eigenschaft). Diese Inkrementlisten werden mit der Diagrammvorlage (.ogg) bzw. der Designdatei (.oth) gespeichert.


:PD Group tab 2015-vNext.png

Das oben stehende Bild zeigt die Einstellungen der Registerkarte Gruppe für ein Punkt-Liniendiagramm in der oberen linken Ecke. Die erste Spalte führt Linienfarbe, Symboltyp, Linienstil, Symbolrandfarbe und Symbol Innen auf. Linienfarbe, Symboltyp und Symbolrandfarbe sind auf das Inkrement Durch Eins Zwischen Untergruppen gesetzt (die Gruppierung erfolgt mit Hilfe der Spalte Langname), während die Inkrementierung von Linienstil und Symbolinneres auf Keine festgelegt ist (sie variieren nicht).

Diese Anordnung ist vollständig benutzerdefiniert anpassbar. Sie können die Anpassungen mit der Diagrammvorlage speichern:

Einzelne Datenpunkte benutzerdefiniert anpassen

Für einige Diagrammtypen wie Punkt- und Säulendiagramme können Sie die Anzeigeeigenschaften eines einzelnen Datenpunkts modifizieren. Dies ist eine andere Diagrammanpassung, die über den Dialog Details Zeichnung durchgeführt wird. Um einen einzelnen Punkt zu bearbeiten, halten Sie die Strg-Taste gedrückt und klicken Sie im Diagramm doppelt auf den Datenpunkt. Der Dialog Details Zeichnung wird geöffnet, um diesen Datenpunkt zu bearbeiten. Beachten Sie, dass der Datenpunkt im linken Bedienfeld von Details Zeichnung über seine Zeilenindexnummer identifiziert wird. Verwenden Sie die Bedienelemente auf den Registerkarten im rechten Bedienfeld, um das Aussehen des Datenpunkts zu verändern. Änderungen haben keinen Einfluss auf das Erscheinungsbild von anderen Punkten in der Datenzeichnung.

PD point-edit mode.jpg

Um Anpassungen, die an einem einzelnen Datenpunkt vorgenommen wurden, zu entfernen:

  • Klicken Sie mit der rechten Maustaste auf den einzelnen Punkt im linken Bedienfeld des Dialogs Details Zeichnung und wählen Sie Entfernen.
  • Klicken Sie im Diagrammfenster auf den einzelnen Punkt, um ihn auszuwählen, und drücken Sie dann Entfernen auf der Tastatur.

Die Eigenschaften des Punkts greifen auf die Eigenschaften des enthaltenen Datensatzes zurück.

Diagrammachsen benutzerdefiniert anpassen

Die meisten Achsenanpassungen werden über den Dialog Achsen vorgenommen. Klicken Sie doppelt auf die Diagrammachse oder die Hilfsstrichsbeschriftungen, um den Dialog Achsen - Layer N zu öffnen.

Sie können jetzt die Layer innerhalb des Dialogs Achsen wechseln. In früheren Versionen mussten Sie die Achsen von jedem Layer in separaten Dialogen benutzerdefiniert anpassen.

 

Dieses Bild zeigt den auf Registerkarten aufgebauten Dialog der Achsen, der von den meisten 2D- und 3D-Diagrammen verwendet wird.

Axis dialog box.png

Im linken Bedienfeld können Sie ein oder mehrere Symbole auswählen (halten Sie zum Auswählen von mehreren Symbolen die Strg-Taste gedrückt), um festzulegen, welche Achse(n) benutzerdefiniert angepasst werden sollen. Wechseln Sie dann zur gewünschten Registerkarte und wählen Sie Ihre Optionen.

Tab Bedienelemente für
Skalierung Skalierungsbereich der Werte, Skalierungstyp, Modus der Neuskalierung, umgekehrte Skalierung sowie große und kleine Hilfsstriche
Beschriftungen der Hilfsstriche Anzeige- und Formatoptionen für die Beschriftung von großen und kleinen Hilfsstrichen, einschließlich benutzerdefinierte Beschriftung nach Formel
Titel Achsentitel (häufig mit Hilfe von Variablennotation festgelegt) und Schriftarten Beachten Sie, dass Sie den Achsentitel direkt bearbeiten können, indem Sie doppelt auf das Textobjekt in dem Diagramm klicken.
Gitternetze Anzeige und Eigenschaften der Gitternetzlinien bei großen und kleinen Hilfsstrichen bearbeiten festlegen
Linie und Hilfsstriche Globale Anzeigeoptionen für Achsenlinie und -hilfsstriche für alle Achsen festlegen
Spezielle Hilfsstriche Sie können spezielle Hilfssstrichsbeschriftungen positionieren.
Referenzlinien Positionierung der Referenzlinien und "Rezessionsbalken" (schattierte Flächen mit Transparenz, die oberhalb einer Datenzeichnung hinzugefügt werden können)
Unterbrechungen Linienunterbrechungen aktivieren und jede Unterbrechung konfigurieren

Klicken Sie auf die Schaltfläche Anwenden auf, um die Achsenformateinstellungen von einer Achse selektiv auf eine andere Achse anzuwenden.

Hinweis: Weitere Informationen zur benutzerdefinierten Anpassung von Achsen und zu weiteren Achsenbedienelemente für spezialisierte Diagrammtypen (z.B. Polar, Ternär, Radar etc.) finden Sie unter:

Hilfe: Origin: Origin-Hilfe > Grafische Darstellung > Diagrammachsen

Diagrammlegenden

Diagrammlegenden automatisch erstellen

Eine Diagrammlegende wird automatisch erstellt, wenn Sie Daten zeichnen. Für 2D- und einige 3D-Diagrammvorlagen erstellt Origin eine Standardlegende, die Informationen über Diagrammstil und Datensatz (Metadaten) kombiniert und das entstehende Beschriftungsobjekt in der oberen rechten Ecke der Diagrammseite positioniert.

Das Standardlegendenobjekt wird mit Hilfe der LabTalk-Substitutionsnotation erstellt. Der Grund dafür ist folgender:

  • Das Legendenobjekt ist in der Lage, der Identifikation dienende Informationen, die in die Spaltenüberschriften eines Arbeitsblatts eingegeben wurden, entweder manuell oder automatisch beim Dateiimport einzubinden.
  • Das Legendenobjekt ist dynamisch mit den gezeichneten Daten verbunden, so dass es aktualisiert werden kann, wenn Daten zum Diagramm hinzugefügt oder daraus entfernt werden. Die Substitutionsnotation wird sichtbar, wenn Sie doppelt in das Legendenobjekt klicken (als wollten Sie es bearbeiten).
Auto Creation of Legend.png.

Die Schreibweise der Legendentexte wird über die Liste Übersetzungsmodus von %(1), %(2) auf der Registerkarte Legenden/Titel des Dialogs Details Zeichnung (Format: Seiteneigenschaften) gesteuert. Das benutzerdefinierte Format der Schreibweise wird unterstützt.

  • Um die automatische Erstellung einer Diagrammlegende zu verhindern, erstellen und passen Sie Ihr Diagramm benutzerdefiniert an. Löschen Sie dann das Legendenobjekt und speichern Sie die Diagrammvorlage unter einem neuen Namen.
  • Klicken Sie mit der rechten Maustaste auf das Legendenobjekt, um auf einige nützliche Bedienelemente zugreifen zu können, wie Umgekehrte Reihenfolge, Legende nur für sichtbare Diagramme zeigen und Legende für angepasste Kurven verbergen.
  • Wählen Sie das Legendenobjekt; drücken Sie dann die Strg-Taste, während Sie an einem der Auswahlelemente ziehen, um das Layout der Legende zu ändern (z.B. ziehen Sie horizontal, um eine Legende zu erstellen, die auf einer Zeile angezeigt wird).
  • Klicken Sie dann doppelt auf den Legendentext, um den direkten Bearbeitungsmodus aufzurufen. Klicken Sie doppelt auf ein Legendensymbol, um den Dialog Details Zeichnung mit entsprechend ausgewählter Zeichnung zu öffnen.

Diagrammlegende oder Skalierungsobjekt hinzufügen und aktualisieren

Es gibt eine Anzahl von Gründen zum Ändern der Standarddiagrammlegende. Wir schlagen vor, Sie lesen sich dieses Thema in der Online-Dokumentation durch, um zu sehen, welche Arten von benutzerdefinierter Anpassung unterstützt werden. Bevor Sie fortfahren, die Datenzeichnungslegende benutzerdefiniert anzupassen, sollten Sie den Unterschied zwischen der Aktualisierung einer Legende und ihrer Rekonstruktion kennen: Durch die Aktualisierung werden Ihre Anpassungen bewahrt, bei der Rekonstruktion geschieht dies nicht. Außerdem sollte beachtet werden, dass die Diagrammvorlage eine Einstellung Modus Legendenaktualisierung speichert, die bestimmt, wie die Legende aktualisiert wird, wenn Datenzeichnungen zu bzw. aus dem Diagramm hinzugefügt oder entfernt werden. Weitere Informationen finden Sie unter Modus Legendenaktualisierung.

Diese Tabelle listet die Aufgaben auf, die mit dem Erstellen und benutzerdefinierten Anpassen der Standardlegende verbunden sind, und die Stellen, wo die jeweiligen Bedienelemente zu finden sind.

Aufgabe Methode (bei aktivem Diagramm)
Legende hinzufügen oder neu erstellen
  • Menü Grafik: Legende: Legende rekonstruieren
  • Schaltfläche Neue Legende Button New Legend.png (Symbolleiste Objekt zu Diagramm hinzufügen)
  • Strg + L

Hinweis: Jegliche Anpassungen an einer bestehenden Legende gehen verloren, wenn Sie diese Menübefehle verwenden.

Legende aktualisieren Öffnen Sie den Dialog legendupdate.
  • Menü Grafik: Legende: Legende aktualisieren
  • Klicken Sie mit der rechten Maustaste auf die Legende und wählen Sie Legende: Legende aktualisieren aus.
Erweiterte Legendenanpassungen Klicken Sie mit der rechten Maustaste auf das Legendenobjekt. Mehrere erweiterte Optionen werden angezeigt, mit denen Sie die Diagrammlegende benutzerdefiniert anpassen können. Wird hauptsächlich angewendet auf:
  • Kategoriale Datenzeichnungen
  • Boxdiagramme
  • Punkt-für-Punkt erzeugte Legenden
Farbskala hinzufügen Nur verfügbar für Diagramme mit Farbabbildung.
  • Klicken Sie auf die Schaltfläche Farbskala hinzufügen Add color scale button.png (Symbolleiste Objekt zu Diagramm hinzufügen).
  • Klicken Sie mit der rechten Maustaste auf den Layer und wählen Neue Farbskala.
  • Menü Grafik: Farbskala hinzufügen
  • Klicken Sie im Fall von mehreren farbkodierten Zeichnungen mit verschiedenen Farbskalen in einem Diagramm auf jede einzelne Zeichnung, um sie auszuwählen und eine entsprechende Farbskala hinzuzufügen.
Eigenschaften der Farbskala steuern Verfügbar, wenn ein Farbskalenobjekt zu einem Diagramm hinzugefügt wurde. Um den Dialog Eigenschaften Farbskala zu öffnen:
  • Klicken Sie doppelt auf das Farbskalenobjekt.
  • Klicken Sie mit der rechten Maustaste auf das Farbskalenobjekt und wählen Sie Eigenschaften.
Blasenskala hinzufügen Verfügbar für Blasendiagramme oder bei Steuerung der Symbolgröße durch einen Datensatz.
  • Wählen Sie Grafik: Neue Blasenskala.
  • Klicken Sie mit der rechten Maustaste auf den Layer und wählen Neue Blasenskala.
  • Klicken Sie auf die Schaltfläche Blasenskala hinzufügenButton Add Bubble Scale.png auf der Symbolleiste Diagramm.
  • Klicken Sie mit der rechten Maustaste auf die Legende, um Blasenskala hinzufügen im Kontextmenü auszuwählen.
Blasenskala steuern

Verfügbar, wenn ein Blasenskalenobjekt zu einem Diagramm hinzugefügt wurde. Um den Dialog Steuerung der Blasenskala zu öffnen:

  • Klicken Sie doppelt auf das Blasenskalenobjekt.
  • Klicken Sie mit der rechten Maustaste auf das Blasenskalenobjekt und wählen Sie Eigenschaften.

Sowohl der Dialog legendupdate als auch die Registerkarte Legende/Titel auf Seitenebene des Dialogs Details Zeichnung bieten Optionen zum Einbinden von Metadateneigenschaften wie Langname, Kommentare, Anwenderparameter etc. in der Diagrammlegende. Metadateneigenschaften können auch mit Hilfe von benutzerdefinierten LabTalk-Notationen kombiniert werden.

Es gibt mehrere Optionen zur weiteren benutzerdefinierten Anpassung der Legende. Diese Anpassungen werden nicht auf Farbskalen angewendet:

  • Klicken Sie mit der rechten Maustaste auf die Legende und wählen Sie Einstellungen. Es werden Bedienelemente zum Formatieren von Schriftart, Größe, Farbe, Hintergrund und Drehung bereit gestellt.
  • Klicken Sie mit der rechten Maustaste auf die Diagrammlegende und wählen Sie Eigenschaften. Ändern Sie Größe, Farbe, Linienbreite und Symbole der jeweiligen Datenzeichnung.
  • Klicken Sie auf den Rahmen der Legende, um Bedienelemente für die Rahmenlinie anzuzeigen, mit denen der Bereich zwischen Text und Rahmen bearbeitet werden kann.
Hinweis: Weitere Informationen zum Erstellen und benutzerdefinierten Anpassen von Legenden finden Sie unter:

Hilfe: Origin: Origin-Hilfe > Grafische Darstellung > Diagrammlegenden und Farbskalen

Aktualisierung der Legende steuern

Wenn eine Datenzeichnung zu einem Diagrammlayer hinzugefügt oder aus ihm entfernt wird, besteht das Standardverhalten darin, die Legende zu aktualisieren. Auf der Registerkarte Legenden/Titel auf Diagrammebene des Dialogs Details Zeichnung befindet sich ein Kontrollkästchen Modus Legende aktualisieren, das dieses Verhalten steuert.

Die Standardeinstellung Aktualisieren beeinflusst nur die Legendenanzeige der Datenzeichnungen, die hinzugefügt oder entfernt werden. Vorherige Anpassungen der Legende für vorhandene Zeichnungen wie manuelle Texteingaben werden beibehalten.

Tutorial: Legende benutzerdefiniert anpassen und Datenzeichnungen hinzufügen

  1. Öffnen Sie ein neues Projekt in Origin.
  2. Öffnen Sie den Windows Explorer und navigieren Sie zu dem Unterordner <Origin>\Samples\Import and Export\
  3. Drücken Sie die Shift-Taste, wählen Sie die Dateien S15-125-03.dat, S21-235-07.dat und S32-014-04.dat und ziehen Sie sie dann per Drag&Drop in eine leere Origin-Arbeitsmappe. Die drei Dateien werden in drei separate Arbeitsmappen importiert.
  4. Klicken Sie auf eine der Arbeitsmappen, markieren Sie Spalte B und erstellen Sie ein Liniendiagramm.
  5. Klicken Sie mit der rechten Maustaste auf die Legende und wählen Sie Legende: Legende aktualisieren, um den Dialog legendupdate zu öffnen.
  6. Wählen Sie in der Liste Autom. Legende die Option Benutzerdefiniert und geben Sie in dem angezeigten Bearbeitungsfeld die Zeichenkette:
    @WS, @LD3
    ein. Klicken Sie auf OK, um den Dialog zu schließen. Die Legende wird aktualisiert und zeigt den Blattnamen und den dritten Anwenderparameter an.
  7. Klicken Sie auf die zweite Arbeitsmappe, markieren Sie Spalte B, klicken Sie am rechten Rand der Spalte, halten Sie die Maustaste gedrückt und ziehen Sie diese Daten dann per Drag&Drop in das Diagramm, um eine zweite Datenzeichnung zu erstellen.
  8. Wiederholen Sie diese Schritte mit Spalte B aus der dritten Arbeitsmappe. Das Diagramm zeigt jetzt drei Datenzeichnungen an, und die Legende aktualisiert automatisch, um den Identifizierer für alle drei Datenzeichnungen anzuzeigen.
  9. Klicken Sie einzeln auf jede Kurve und verwenden Sie die Symbolleiste Stil, um eine unterschiedliche Linienfarbe für jede Kurve festzulegen. Die Legende wird automatisch aktualisiert und zeigt die neue Linienfarbe an.

GSB Legend Tutorial.png

Spezielle Legendentypen

Origin verfügt über mehrere spezielle Legenden, die mit bestimmten Diagrammtypen zusammen verwendet werden. Diese Legenden können benutzerdefiniert angepasst und aktualisiert werden, ähnlich dem Standardlegendenobjekt.

Legendentyp Menübefehl Wird verwendet, wenn...
Legende für kategoriale Werte Grafik: Legende: Kategoriale Werte Mindestens eine Zeichnungseigenschaft (z.B. Farbe, Symbolform etc.) wird vom Datenindex gesteuert. Siehe Legende für kategoriale Werte in der Online-Dokumentation.
Punkt-für-Punkt-Legende Grafik: Legende: Punkt für Punkt Der Symbolstil wird von dem Datenindex, der Inkrementliste oder der Farbabbildung gesteuert. Siehe Punkt-für-Punkt-Legende in der Online-Dokumentation.
Legende für Komponenten von Boxdiagrammen Grafik: Legende: Boxdiagrammkomponenten Das Diagramm ist ein Boxdiagramm oder ein gruppiertes Boxdiagramm. Siehe Legende für Boxdiagrammkomponenten in der Online-Dokumentation.

Anmerkungen zu Ihrem Diagramm hinzufügen

Ein Diagramm mit Anmerkungen zu versehen kann so einfach sein, wie ein statisches Textobjekt hinzuzufügen und dieses mit der Symbolleiste Format zu formatieren. Sie können aber auch ein komplexeres Objekt hinzufügen, das mit einem LabTalk-Skript verknüpft ist, das immer dann ausgeführt wird, sobald ein bestimmtes vom Anwender festgelegtes Ereignis eintritt (z.B. Objekt wird verschoben, Fenster wird aktiviert, Diagrammachsen werden neu skaliert etc.).

Aufgabe Methode
Datenpunkte beschriften
  • Wählen Sie Format: Diagrammeigenschaften, klicken Sie dann auf die Registerkarte Beschriftung und aktivieren Sie Aktivieren (nicht verfügbar für alle Zeichnungstypen).
  • Um einzelne Punkte mit Anmerkungen zu versehen, siehe unten "Anmerkung zu einem Datenpunkt hinzufügen".
Textobjekte hinzufügen
  • Klicken Sie auf das Hilfsmittel Text einfügen Button Text Tool.png und dann auf das Diagramm, um das Objekt zu positionieren.
  • Klicken Sie mit der rechten Maustaste auf das Diagramm und wählen Sie im Kontextmenü Text hinzufügen.
  • Klicken Sie doppelt auf den Text, um ihn mit RichText zu bearbeiten.
Layertitel hinzufügen
  • Klicken Sie mit der rechten Maustaste auf das Diagramm und wählen Sie Layertitel hinzufügen/modifizieren im Kontextmenü, um einen Layertitel im aktiven Layer einzufügen oder diesen zu ändern.
Vertikale/Horizontale Linie hinzufügen
  • Wählen Sie bei aktivem 2D-Diagramm Grafik: Gerade hinzufügen.
Einen Datenpunkt mit einer Anmerkung versehen
  • Klicken Sie auf das Hilfsmittel Anmerkung Button Data Annotation.png auf der Symbolleiste Hilfsmittel.
Zeichenobjekte hinzufügen Verwenden Sie die entsprechenden Schaltflächen auf der Symbolleiste Hilfsmittel. Origin unterstützt:
  • Pfeil, gekrümmter Pfeil
  • Linie, Polylinie, Freihand
  • Rechteck, Kreis, Polygon, Bereich
Gleichung, Word-Objekt, Excel-Objekt, weiteres OLE-Objekt einfügen
  • Gruppe Gleichung einfügen auf der Symbolleiste Hilfsmittel
Bild einfügen
  • Klicken Sie mit der rechten Maustaste auf das Diagramm und wählen Sie Bilder aus Dateien einfügen.
Tabelle einfügen
  • Klicken Sie auf die Schaltfläche Neue Verknüpfungstabelle Button New Link Table.png auf der Symbolleiste Objekt zu Diagramm hinzufügen und dann auf das Diagramm.
  • Klicken Sie mit der rechten Maustaste auf das Diagramm und wählen Sie im Kontextmenü Neue Tabelle.
  • Klicken Sie doppelt auf das Tabellenobjekt, um die Tabelle zu bearbeiten und benutzerdefiniert anzupassen.
Datums- & Zeitstempel einfügen
  • Schaltfläche Datum & Zeit Button Date Time.png auf der Symbolleiste Objekt zu Diagramm hinzufügen
Projektpfad einfügen
  • Schaltfläche Projektpfad Button Project Path.png auf der Symbolleiste Objekt zu Diagramm hinzufügen
Klammern mit Sternchen hinzufügen
  • Um statistische Gruppierungen zu kennzeichnen, klicken Sie auf die Schaltfläche Klammern mit Sternchen hinzufügen Button Add asterisk bracket.png auf der Symbolleiste Objekt zu Diagramm hinzufügen. Passen Sie die Größe und Position der Klammern durch Ziehen an den Bedienelementen auf dem Objekt manuell an.
XY-Skala hinzufügen Diese Option ist nützlich, wenn Sie eine nichtlineare XY-Skala verwenden.
  • Klicken Sie auf die Schaltfläche Skala einfügen Button Add XY Scale.png und dann auf ein Diagrammlayer.
  • Klicken Sie mit der rechten Maustaste auf ein Diagrammlayer und wählen Sie Neue XY-Skala im Kontextmenü.

Tipps zum Bearbeiten der Diagrammanmerkungen

  • Wenn Sie beim Zeichnen mit den Hilfsmitteln Rechteck Button Rectangle Tool.png oder Kreis Button Circle Tool.png die Strg-Taste drücken, wird ein Quadrat oder ein Kreis gezeichnet (im Gegensatz zu einem Rechteck bzw. einer Ellipse).
  • Klicken Sie mit der rechten Maustaste auf ein Objekt und wählen Sie Einstellungen, um die Eigenschaften des Texts oder des Zeichnungsobjekts zu bearbeiten und den Standard festzulegen.
  • Verwenden Sie die Schaltflächen der Symbolleisten Format und Stil, um schnell einige Zeichnungselemente und Achsentitel zu modifizieren.
  • Textobjekte, einschließlich Achsentitel, können Sie im direkten Bearbeitungsmodus bearbeiten. Klicken Sie doppelt auf ein zu bearbeitendes Textobjekt. Verwenden Sie die Schaltflächen der Symbolleiste Format, um hoch- und tiefgestellte sowie griechische Zeichen hinzuzufügen.
  • Wenn Sie sich im direkten Bearbeitungsmodus befinden, können Sie mit der rechten Maustaste klicken und Abbildung Symbole wählen, um Sonderzeichen in Ihr Textobjekt einzufügen.
  • Sie können den Inhalt einer Arbeitsblattzelle (Daten oder Metadaten) in ein Textobjekt einfügen, indem Sie den Zelleninhalt kopieren und dann, während Sie sich im direkten Bearbeitungsmodus des Textobjekts befinden, mit der rechten Maustaste klicken und im Kontextmenü Einfügen oder Verknüpfung einfügen wählen.
  • Sie können im direkten Bearbeitungsmodus mit der rechten Maustaste klicken und Info Variable einfügen wählen, um Informationen, die sich auf die gezeichneten Daten beziehen, in das Textobjekt einzufügen.
  • Sie können mit Hilfe von LabTalks Substitutionsnotation % und $ Variablenwerte in ein Textobjekt einfügen, indem Sie im Dialog Textobjekt - Text des Textobjekts auf der Registerkarte Programmierung die Option Verknüpfung zu (%,$), Substitutionsebene auf 1 setzen. Klicken Sie mit der rechten Maustaste auf das Textobjekt und wählen Sie Eigenschaften im Kontextmenü.
  • Sie können die Bedienelemente auf der Registerkarte Programmierung verwenden, um LabTalk-Skript mit einem Text- oder einem Zeichenobjekt zu verbinden (siehe zum Beispiel Textbeschriftungen mit Daten und Variablen verknüpfen). Geben Sie Ihr Skript in das Textfeld ein und legen Sie eine Bedingung für Kriterien für Skriptausführung zum Ausführen des Skripts fest. Verwenden Sie die Auswahlliste Anwenden auf, um den Umfang für das Skript festzulegen.
  • Sie können einen Bereich (von Zellen) aus einer Arbeitsmappe kopieren und ihn in ein Diagramm in Form eines Tabellenobjekts einfügen. Das Tabellenobjekt ist bearbeitbar.

Objektverbindung und Skalierung

Wenn Sie in ein Origin-Diagrammfenster einen Text oder ein Zeichenobjekt einfügen, wird das Objekt Teil des aktiven Diagrammlayers. Dies ist wichtig zu beachten, weil Sie, wenn Sie die Größe eines Diagrammlayers verändern bzw. den Layer löschen, die Objektgröße verändern können, das Objekt aber löschen werden.

Um die Methode zum Verbinden eines Texts oder eines Zeichenobjekts anzuzeigen bzw. zu bearbeiten:

  1. Klicken Sie mit der rechten Maustaste auf ein Text- oder Zeichenobjekt und wählen Sie Eigenschaften.
  2. Klicken Sie auf die Registerkarte Programmierung und beachten Sie die Objekteinstellung Anhängen an.

Object Properties Attachment.png

Obwohl Objekte ein Teil des Layers sind, der zum Zeitpunkt ihrer Erstellung aktiv ist, können Sie das Objektverhalten steuern, indem Sie die Verbindungsmethode des Objekts ändern. Ein Objekt mit einer von drei verschiedenen Methoden angehängt:

  • Seite Wenn Objekte mit der Seite verbunden werden, werden sie durch Verschiebung oder Größenveränderung des Layers nicht beeinflusst. Auch eine Änderung der Achsenskalierungen beeinträchtigt sie nicht. Sie sind jedoch noch immer mit einem besonderen Diagrammlayer verbunden und werden verborgen oder gelöscht, wenn der Layer verborgen oder gelöscht wird.
  • Layerrahmen Objekte, die mit dem Layerrahmen verbunden werden, werden mit dem Layerrahmen in der Größe verändert und verschoben, bleiben aber ansonsten unberührt von den Änderungen der Achsenskalierungswerte in dem Layer. Objekte werden verborgen oder gelöscht, wenn der verbundene Layer verborgen oder gelöscht wird.
  • Layer und Skalen. Objekte werden mit einem bestimmten Bereich der Achsenskalierungswerte verknüpft. Wenn Sie die Größe des Layers verändern, wird die Objektgröße entsprechend verändert. Wenn Sie die Achsen neu skalieren, verschiebt sich das Objekt im Verhältnis zur Skalierungsänderung und erscheint nicht in der Ansicht, wenn der verbundene Achsenskalierungsbereich nicht angezeigt wird. Objekte werden verborgen oder gelöscht, wenn der verbundene Layer verborgen oder gelöscht wird.

Die folgende Tabelle fasst die Standardmethoden zum Verbinden von allgemeinen Objekten zusammen. Beachten Sie, dass die Standardmethode je nach Objekttyp variiert.

Objekttyp Bei Erstellung innerhalb des Layerrahmens
ist das Objekt verbunden mit...
Bei Erstellung außerhalb des Layerrahmens
ist das Objekt verbunden mit...
Text Layerrahmen Seite
Rechteck, Kreis, Polygon, Region, Polylinie, Freihand Layerrahmen Seite
Pfeil, Linie, gekrümmter Pfeil Layer und Skalierungen Seite


Hinweis: Weitere Informationen zu Methoden der Objektverbindung finden Sie unter:

Hilfe: Origin: Origin-Hilfe > Grafische Darstellung > Text- und Zeichenobjekte hinzufügen > Objektverbindung und Skalierung

Gruppieren, Ausrichten und Anordnen mit der Symbolleiste Objekte bearbeiten

Tutorial81 Merging and Arranging Graphs Object Toolbar.png

Sie können Textbeschriftungen und Zeichenobjekte gruppieren, so dass sie als Einheit verschoben oder in der Größe verändert werden:

  1. Um Objekte auszuwählen, drücken Sie Shift und klicken Sie oder ziehen Sie ein Feld mit dem Hilfsmittel Zeiger Button Pointer.png auf.
  2. Um ausgewählte Objekte zu gruppieren, klicken Sie auf die Schaltfläche Gruppieren Group button.png auf der Symbolleiste Objekt bearbeiten.
  3. Um die Gruppierung von Objekten aufzuheben, klicken Sie auf die Schaltfläche Gruppierung aufheben Button Ungroup.png auf der Symbolleiste Objekt bearbeiten.


Sie können Textbeschriftungen und gezeichnete Objekte mit Hilfe des Hilfsmittels auf der Symbolleiste Objekt bearbeiten ausrichten:

  1. Wählen Sie die auszurichtenden Objekte aus, indem Sie während der Auswahl die Shift-Taste gedrückt halten (oder ziehen Sie ein Auswahlfeld mit dem Hilfsmittel Zeiger Button Pointer.png auf) und klicken Sie auf eine der Ausrichtungsschaltflächen auf der Symbolleiste. Beachten Sie, dass Objekte im Bezug zu dem als erstes ausgewählten Objekt ausgerichtet werden.


Sie können die sich überschneidenden Objekte in den Vordergrund oder in den Hintergrund schieben:

  1. Wählen Sie die Objekte aus, die Sie in den Vorder- oder Hintergrund schieben möchten.
  2. Klicken Sie auf die Schaltfläche Vordergrund Button Front.png oder Hintergrund Button Back.png auf der Symbolleiste Objekt bearbeiten.
Hinweis: Weitere Informationen zu Diagrammanmerkungen finden Sie in der Origin-Hilfe:

Hilfe: Origin: Origin-Hilfe > Grafische Darstellung > Text- und Zeichenobjekte hinzufügen

Sie können auch die Symbolleiste Objekt bearbeiten verwenden, um Diagrammlayer zu verändern. Ausgewählte Diagrammlayer reagieren genau wie Text- bzw. Zeichenobjekte. Verwenden Sie es, um mehrere Diagrammlayer auszurichten und eine einheitliche Größe für sie festzulegen oder um die Layerordnung zu vertauschen.

Diagramme und Layer anordnen

Aufgabe Methode
Mehrere Diagrammfenster zu einem einzelnen Diagrammfenster zusammenfügen
  • Menü Grafik: Grafikfenster zusammenfügen.

oder

  • Schaltfläche Zusammenfassen Button Merge.png auf der Symbolleiste Diagramm
Datenzeichnungen von einem Layer in mehrere Layer extrahieren
  • Schaltfläche In Layer extrahieren Button Extract To Layers.png auf der Symbolleiste Diagramm Hinweis: Um Ihr ursprüngliches Diagramm zu bewahren, klicken Sie auf die Schaltfläche Duplizieren Button Duplicate.png, bevor Sie in die Layer extrahieren.
Mehrere Layer aus einem Diagramm in mehrere Diagrammfenster extrahieren
  • Menü Grafik: In Grafiken extrahieren

oder

  • Klicken Sie auf die Schaltfläche In Grafiken extrahieren Button Extract To Graphs.png auf der Symbolleiste Diagramm.

Jeder Layer wird in ein einzelnes Diagrammfenster weitergegeben, selbst wenn ein Layer mit einem anderen verbunden ist.

Standardmäßig sind die Extrahierten Layer auf 1:0 gesetzt, wodurch festgelegt wird, dass alle Layer extrahiert werden. Um nur in bestimmten Layern zu arbeiten, deaktivieren Sie Auto und verwenden Sie die Notation der X-Funktion layextract mit Komma/Doppelpunkt, um auf bestimmte Layer zu verweisen. Die Notation 1:0 bedeutet, dass mit Layer 1 begonnen wird und alle Layer in Diagramme extrahiert werden (0 steht für alle). Die Angabe von 1,3:4 sagt Origin beispielsweise, dass nur der erste, dritte und vierte Layer extrahiert werden.

Layer hinzufügen, anordnen, in der Größe verändern, positionieren, austauschen, ausrichten oder verknüpfen Menü Grafik: Layerverwaltung

Hinweis: Um Positionen von Layern in einer Ebene physisch zu vertauschen (weisen Sie die Layernummer nicht neu zu!), verwenden Sie die Funktion Vertauschen (Registerkarte Größe/Position) des Hilfsmittels Layerverwaltung (Grafik: Layerverwaltung).

Diagrammlayer verknüpfen
  • Registerkarte Achsen verbinden auf Layerebene des Dialogs Details Zeichnung
  • Registerkarte Verknüpfung des Dialogs Layer-Management

Wenn Layer verknüpft werden, muss der Unterlayer eine höhere Layernummer haben als der Hauptlayer.

Verknüpfte Layer können zusammen verschoben und in der Größe verändert werden.

Sie können die Achsenskalierungswerte der Layer mit der Option Gerade (1 zu 1) verknüpfen oder Sie können eine benutzerdefinierte mathematische Beziehung festlegen.

Layer neu ordnen

Es gibt mehrere Möglichkeiten, Diagrammlayer neu zu ordnen (Neuzuweisung der Layernummer für jeden Layer). Sie können mehr über die Neuzuweisung von Layernummern in dem Mini-Tutorial unter dieser Tabelle erfahren.

  • Methode 1: Öffnen Sie den Dialog Layer-Management, klicken Sie auf den Zeilenkopf (im Bild unten zu sehen) und ziehen Sie ihn nach oben oder nach unten, um die Layerordnung zu ändern.

Swap area.png

Weitere Informationen finden Sie im Abschnitt zum Hilfsmittel Layerverwaltung.

  • Methode 2: Geben Sie das folgende LabTalk-Skript im Befehlsfenster (Fenster: Befehlsfenster) ein und drücken Sie dann zum Ausführen Enter.

page.reorder(n,m)

Der Befehl verwandelt den n-ten Layer in den m-ten Layer.

  • Methode 3: Verwenden Sie die Schaltflächen Vorn und Hinten auf der Symbolleiste Objekt bearbeiten (diese Schaltflächen funktionieren auf dem aktiven Layer, wie durch das Symbol des Diagrammlayers Layer icon active.png angegeben). Alternativ können Sie mit der rechten Maustaste auf das Symbol des Diagrammlayers klicken und die Layerordnung mit Hilfe von Kontextmenübefehlen ändern.


Hinweis: Das Neuordnen der Layer kann Beziehungen durch Layerverknüpfung beeinträchtigen.

XY-Achsen austauschen
  • Menübefehl Grafik: X-Y-Achsen vertauschen
  • Schaltfläche Achsen austauschen auf der Symbolleiste Diagramm

In einer Grafik mit mehreren Layern wird die Zeichenreihenfolge von der Layerordnung bestimmt. Der erste Layer wird gezeichnet, danach der zweite Layer darüber und so weiter. Der Layer mit der höheren Nummer wird auf dem Layer mit den niedrigeren Nummer gezeichnet. Dies ist wichtig, wenn Zeichnungen in einem Layer Zeichnungen in einem anderen Layer überlagern. Wenn notwendig, können Sie die Layerordnung ändern, um die Zeichenreihenfolge der Zeichnungen zu ändern.

Dieses kleine Tutorial zeigt Ihnen, wie der Vorgang der Layerneuzuweisung vonstatten geht. Verwenden Sie das Vorschaufenster, um zu sehen, wie die Neuzuweisung der Layernummern Ihr Diagramm beeinflussen.

  1. Klicken Sie auf Hilfe: Origin-Navigator oder drücken Sie F11.
  2. Klicken Sie auf die Registerkarte Diagrammbeispiele, setzen Sie die Auswahlliste Beispiel für auf Fläche und klicken Sie doppelt auf dieses Diagramm:
    Custom graph layermanage tutorial.png
  3. Aktivieren Sie das Diagramm Area Plot With Horizontal Color Gradient und klicken Sie dann auf die Schaltfläche In Layer extrahieren Button Extract To Layers.png auf der Symbolleiste Diagramm. Setzen Sie sowohl die Anzahl der Zeilen als auch der Spalten auf 1, klicken Sie auf OK und dann für den Seitenabstand erneut auf OK. Der grüne Layer befindet sich in dem Bild auf dem gelben Layer. Der Zweck dieses letzten Schrittes war einfach das Erstellen eines Diagramms mit zwei Layern, in dem die Daten in dem einen Layer die Daten des anderen Layers teilweise verbergen. Was wir jetzt tun werden ist, die Layer neu zu ordnen und den gelben Layer für die Position oben festzulegen, so dass Sie eine besser Ansicht der zwei Zeichnungen haben.
    Reorder1.png
  4. Wählen Sie im Menü Grafik: Layer-Verwaltung, ziehen Sie dann den Zeilenkopf "1" von Layer1 in der Layerauswahl unter Layer2 (durch eine blaue Linie gekennzeichnet) und klicken Sie auf OK.
  5. Sie können sehen, dass der gelbe Layer jetzt oben ist.
    Reorder2.png


Alternative Methode:

In Origin 2017 können Sie die Schaltflächen Vorn Button Front.png oder Hinten Button Back.png (Symbolleiste Objekt bearbeiten) verwenden, um einen Layer nach vorn zu holen oder ihn nach hinten zu verschieben.

 

  1. Aktivieren Sie das Flächendiagramm mit den zwei Layern und klicken Sie dann abwechselnd auf die Schaltflächen Hintern und Vorn, um den gelben Layer nach vorn oder hinten zu verschieben. Wie bei der Methode mit der Layerverwaltung vertauscht diese Methode die Layernummern.

Sie können einen eingesetzten Layer mit Daten einfach einfügen, indem Sie auf die Schaltfläche Eingefügtes Diagramm mit Daten hinzufügen Button Add Inset Graph With Data.png auf der Symbolleiste Diagramm oder im Menü auf Grafik: Neuer Layer(Achsen): Einfügen mit Daten (Verknüpfte Dimension) klicken.

Sie können einen Layer aus einem in ein anderes Diagrammfenster kopieren. Klicken Sie, um zunächst den Layer zu markieren (ein Rahmen wird um den Layerrahmen herum angezeigt). Drücken Sie dann Strg+C oder klicken Sie mit der rechten Maustaste und wählen Sie Kopieren. Wechseln Sie zum Zielfenster und klicken Sie im Kontextmenü auf Einfügen.

Hinweis: Weitere Informationen zum Zusammenfügen von Diagrammen finden Sie in der Origin-Hilfe:

Hilfe: Origin: Tutorials > Grafische Darstellung > Layer > Layer zusammenfügen und anordnen

Hilfe: Origin: Origin-Hilfe > Grafische Darstellung > Referenz > Dialog Grafiken zusammenfügen

Vorlagen und Designs

Origins flexible Hierarchie Seite > Layer > Zeichnung plus eine umfangreiche Liste von bearbeitbaren Objekteigenschaften machen die benutzerdefinierte Anpassung und Speicherung Ihrer Diagrammeinstellungen für eine wiederholte Verwendung einfach. Sie können Ihre benutzerdefinierten Einstellungen auf unterschiedliche Weise bewahren -- entweder als Vorlagen oder als Designs. Diese Konzepte werden unten eingeführt.

Hinweis: Detaillierte Informationen finden Sie in der Origin-Hilfe unter:

Hilfe: Origin: Origin-Hilfe > Grafische Darstellung > Diagramme aus Diagrammvorlagen erstellen

Hilfe: Origin: Origin-Hilfe > Anpassen eines Diagramms > Diagrammformate und Diagrammdesigns

Vorlagen

Anpassungen Ihres Diagramms können in Vorlagendateien zur wiederholten Verwendung gespeichert werden. Beispielsweise können Sie eine Diagrammseite so anpassen, dass mehrere Layer hinzugefügt, Beziehungen zwischen den Layern eingerichtet und Diagrammeigenschaften verändert werden, und all diese Attribute schließlich als eine Diagrammvorlage (.OTP) speichern. Sie können weiterhin festlegen, dass die Diagrammvorlage "klonbar" ist und Ihnen ermöglicht, diese Diagrammanpassungen mit Langname, Kurzname bzw. Arbeitsblattspaltenindexnummer des Datensatzes zu verknüpfen und Ihr Diagramm schnell mit neuen Daten neu zu erstellen.

Einige Hinweise:

  • Origin besitzt mehr als 100 standardmäßige Diagrammvorlagen. Diese "System"vorlagen werden im Origin-Programmordner installiert. Diese Vorlagen sind benutzerdefiniert anpassbar, aber Sie können die Vorlagendateien in Ihrem Softwareordner nicht überschreiben.
  • Standardmäßig werden neue leere 2D-Diagramme aus der Vorlage ORIGIN.otp erstellt. Weitere Diagrammfenster verwenden andere Vorlagen, die mit einer Reihe von Anpassungen entsprechend einer spezifischen Vorlage gespeichert sind.
  • Sie können eine Systemvorlage benutzerdefiniert anpassen und unter dem gleichen Dateinamen in Ihrem Anwenderdateiordner speichern. Wenn die Systemvorlage die mit einem Menübefehl oder der Symbolleistenschaltfläche verbundene Standardvorlage war (z. B. ORIGIN.otp und die Schaltfläche Neue Grafik New Graph.png), dann wird die benutzerdefinierte Vorlage die neue Standardvorlage und auch sie ist mit dem Befehl bzw. der Schaltfläche verbunden.
  • Um System- oder benutzerdefinierte Diagrammvorlagen anzuzeigen, klicken Sie auf Zeichnen (es sollte eine Arbeitsmappe oder Matrix aktiv sein) wählen Sie unter Vorlagen die Option Anwender- oder Systemvorlagen.
  • Sie können eine Diagrammvorlage an einem beliebigen Speicherort und unter jedem gewünschten Namen speichern -- sie muss nicht mit dem Namen einer Systemvorlage gespeichert werden. Durch das Speichern Ihrer Vorlagen in Ihrem Anwenderdateiordner sammeln Sie sie an einem einzigen, gut merkbaren Ort.
Template Library 2016 GSB.png

Designs und Format kopieren/einfügen

Ein Origin-Design ist eine Datei, die eine Reihe von Objekteigenschaften enthält. Es gibt vier Arten von Designdateien in Origin: Diagrammdesigns, Arbeitsblattdesigns, Dialogdesigns und Designs fürs Funktionsdiagramme. Diagrammdesigns sind eine Sammlung von Eigenschaften verschiedener Elemente in einem Diagrammfenster (z.B. könnte ein Design so einfach sein wie beispielsweise Einstellungen für die Richtung der großen und kleinen Hilfsstriche von Achsen, einer Farbabbildung für eine Zeichnung oder eine Kombination der Seitendimensionen, Layerhintergrund, Achsenskalierungen, in einer Zeichnung verwendete Farbpaletten etc.

Mit Designs können Sie schnell eine oder mehrere Objekteigenschaften in einem bestehenden Diagramm ändern oder eine festgelegte Zusammenstellung von Eigenschaften auf alle Diagrammfenster anwenden. Sie können zum Beispiel ein Schwarzweiß-Design auf eines Ihrer farbigen Diagramme anwenden, um es für eine Veröffentlichung in einer Fachzeitschrift vorzubereiten. Oder Sie können die Schriftart in all Ihren Diagrammfenstern in Times New Roman ändern.

Die Eigenschaften, die als ein Design gespeichert werden können, unterscheiden sich in Abhängigkeit von dem ausgewählten Objekt. Grundsätzlich funktioniert es wie folgt:

  1. Klicken Sie mit der rechten Maustaste auf ein Objekt in einem Diagrammfenster, z.B. eine Zeichnung, und wählen Sie Format kopieren. Abhängig davon, worauf Sie klicken, stehen im Kontextmenü Optionen unter Format kopieren zur Verfügung, mit denen Sie wählen können, welche genaue Format kopiert werden soll.
    • Um die kopierten Formate auf ein einzelnes Diagramm anzuwenden, klicken Sie mit der rechten Maustaste auf Ihr Zieldiagramm und wählen Sie Format einfügen in. Erneut finden Sie ein Kontextmenü für Format einfügen mit Optionen, die das Einfügen einschränken. Die Formatierungsoptionen Ihres Quelldiagramms sollten auf Ihr Zieldiagramm angewendet werden.
    • Um die kopierten Formate auf mehrere Fenster in dem Projekt anzuwenden, lassen Sie das Quelldiagramm aktiv und wählen Sie Bearbeiten: Format einfügen im Origin-Menü. Der Dialog Formate anwenden geöffnet. Sie haben hier die Option, die Formate zu bearbeiten bzw. sie selektiv auf ein oder mehrere Diagrammfenster im Origin-Projekt anzuwenden.
  2. Sie können die oben beschriebene Methode zum Kopieren und Einfügen des Formats verwenden oder Sie können im Kontextmenü Format als Design speichern... wählen anstatt Format kopieren. Verwenden Sie Hilfsmittel: Designs verwalten, um das Design in Zukunft anzuwenden.

Designs verwalten

Verwenden Sie Designs verwalten (Hilfsmittel: Designs verwalten), um Designs zu verwalten und sie auf Diagramme anzuwenden. Mit diesem Dialog können Sie ein Diagrammdesign auf mehrere Diagramme gleichzeitig in dem Origin-Projekt anwenden.

Um mehrere Designs im Dialog Designs verwalten zu kombinieren:

  1. Drücken Sie die Strg-Taste, während Sie die Designs markieren, klicken Sie dann mit der rechten Maustaste und wählen Sie Kombinieren im Kontextmenü. Das Kontextmenü in dem Hilfsmittel bietet Ihnen eine Option zum Bearbeiten eines Designs. Sie können Eigenschaften zu einem bestehenden Design hinzufügen oder sie aus ihm entfernen.


Graph theme organizer.png

  • Wenn Sie mit der rechten Maustaste auf ein Diagrammdesign klicken und es als Ihr Systemdesign unter Designs verwalten speichern, wird das Systemdesign jedes Mal angewendet, wenn Sie ein neues Diagramm zeichnen unabhängig von den Einstellungen, die mit der Diagrammvorlage gespeichert sind.
  • Wenn Sie nicht möchten, dass ein Systemdesign automatisch auf das Diagramm angewendet wird, wählen Sie Datei: Template speichern unter und stellen Sie sicher, dass das Kontrollkästchen Aufhebung durch Systemdesign zulassen deaktiviert ist.
  • Sie können ein Diagrammdesign in dem Dialog Grafik exportieren laden. Das Design wird auf die exportierte Bilddatei angewendet.

Weiterführende Themen

 

© OriginLab Corporation. Alle Rechte vorbehalten.